True Street Cars Forums banner
1 - 14 of 14 Posts

·
Phantom
Joined
·
222 Posts
Discussion Starter · #1 ·
Its a 1980 Corsica. When you start the car it will idle fine, but the moment you put it into reverse it dies....

Anyone know anything pertaining to this?
 

·
Premium Member
Joined
·
5,629 Posts
Since it idles it's probably not electrical, but I would do the plugs anyway. Maybe fuel filter and/or pump? I'd replace those too. There's a possibility the tranny is having issues too, but I doubt it.
 

·
Registered
Joined
·
43 Posts
i know my vette did that after the battery as unplugged.. it freaked the guy out at audio express.. we just had to do something weird with turning the key for ten seconds then pulling the key out then it ran fine.. but ya it would idle fine then when it went into gear it would just die out completly
 

·
Overboosted
Joined
·
1,273 Posts
We had an Altima at work that had a similar problem. It turned out that the plugs were all fouled (and misfiring like crazy!) and the distributor was turned to full retard (way off). Put in new plugs and adjusted the timing and it ran great.
 

·
E85 veteran
Joined
·
2,808 Posts
Does it die when put in drive? If so it probably just needs a tune up. If its idling like crap in park I bet a coil is out. Ive replaced two on mine. But it ran on 4 cylinders, ran like shit but it ran.

I dont belive its a Crosica because they are ****en tanks and they always run lol.
 

·
Phantom
Joined
·
222 Posts
Discussion Starter · #12 ·
Does it die when put in drive? If so it probably just needs a tune up. If its idling like crap in park I bet a coil is out. Ive replaced two on mine. But it ran on 4 cylinders, ran like shit but it ran.

I dont belive its a Crosica because they are ****en tanks and they always run lol.
lol

It only dies in reverse, works fine in drive.
 

·
E85 veteran
Joined
·
2,808 Posts
lol

It only dies in reverse, works fine in drive.

I am being 100% seriuos with this next comment. Its a Corsica, dont use reverse.

I remember mine would not lock into park and the e brake did not work. I parked it against stuff to keep it from rolling.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top