True Street Car Forums banner
1 - 11 of 11 Posts

·
In the slow lane
Joined
·
230 Posts
Discussion Starter · #1 ·
Aparently driving the Z06 through what looked like a few inches of moving water, turned out to be me attempting to cross the goddamn Mississipi. The motor made a huge popping sound and its leaking oil everywhere.
I had to push it home in the rain. that sucked. Looks like the motor went to a better place. Though im not sure what would cause the oil leakage?
Oh well. Looks like its time for me to stop fucking around with a heads/cam motor and get that shit fully built. Any sugestions for a replacement? im thinking built longblock (418 or 427) from texas speed
 

·
Premium Member
Joined
·
6,225 Posts
Welcome to the wonderful world of hydrolocked LS1's. My money is on a cracked block. That sucks dick man. Personally, I'd put a big LSX in it, 454ci. Solid-Tech can do it. They can get the motor and everything from TSP or build you a custom one.
 

·
FUCK FOURLOKO!!
Joined
·
10,258 Posts
hydro locking motors sucks but at least its forcing you to become fast. If that ever happened to me I would avoid even the smallest of puddles afterwards.
 

·
I'm kind of a big deal...
Joined
·
2,045 Posts
:( Keep us posted..
 

·
Fat white guy
Joined
·
762 Posts
What the fuck is rain? I didn't know we got that shit in NM. Or is today our day for the rain for the year.
 

·
FUCK FOURLOKO!!
Joined
·
10,258 Posts
There was a river going down academy, water was up over the curb. The little corrola almost didn't have enough power to get through it
 
1 - 11 of 11 Posts
Top