True Street Car Forums banner

1 - 11 of 11 Posts

·
Whippled Charged...
Joined
·
1,085 Posts
Discussion Starter #1
So awhile back I was driving the cobra and while in Wot in between shifts the car has a hesitation and loses power. (Kinda feels like I missed a gear but didnt) The check engine light did not come on. Feels like maybe a fuel issuse. Havent driven the car much in the past few months and took it out tonight and problem is still there. Any advice?:banghead:
 

·
3rd Gear
Joined
·
309 Posts
Take it to DYNO EDGE. It sounds like a tuning problem
 

·
Rustlin' Jimmies
Joined
·
6,254 Posts
Do you have the PPRV delete done? If not, my money is on that.


-edit: actually I'm pretty confident that is your problem, drop the tank and replace the factory lines from the pumps to the hat and eliminate the white check valve thats inline. It sounds much harder to do than it is. Make sure to use submersible rated hose (Gates 30R10 or equivelant), Lethals kit isn't that bad of a deal actually.
 

·
Whippled Charged...
Joined
·
1,085 Posts
Discussion Starter #4
Is this a part that just fails. I didnt have this problem till the car was retuned?
 

·
Rustlin' Jimmies
Joined
·
6,254 Posts
I don't know if it just fails or not but my car used to do the same thing when shifting hard from 2nd to 3rd, went into gear but felt almost like a revlimiter or ignition cut out. After the new fuel system went in with the valve delete no more buck and surge.

If it happened right after a re-tune then it may be in there, but I'd go after that valve as well.
 

·
Whippled Charged...
Joined
·
1,085 Posts
Discussion Starter #6
I don't know if it just fails or not but my car used to do the same thing when shifting hard from 2nd to 3rd, went into gear but felt almost like a revlimiter or ignition cut out. After the new fuel system went in with the valve delete no more buck and surge.

If it happened right after a re-tune then it may be in there, but I'd go after that valve as well.
Who did your fuel system Strech? What did you end up going with?
 

·
Rustlin' Jimmies
Joined
·
6,254 Posts
CHZBRGR and I did it in my garage. It's pretty basic right now.
Dual GT pumps, dual FPDM's and harness from Lethal, 60lb injectors and the PPRV delete.
 

·
Cyber Bully
Joined
·
1,843 Posts
:boobs:

Didn't expect there to be no one posting in the SC section for two months so didn't bother to check the date. I had some bad hesitation in my car and one of my small ground cables to the front of the radiator support was corroded inside nasty. Rewired it, and it solved my hesitation issue. Just offering my personal experience.


Edit: Thread date owns me. Goddamn ABQ Fast Ford mother fucker.
 
1 - 11 of 11 Posts
Top